Does anyone have a rooted Samsung Device?

We are having a really tough time with Samsung device compatibility as of patch 1.4.0. Nearly all of our 1 star reviews on google play (since the last update) are Samsung device owners that are having a tough time getting this patch to work.

At the office we have 9 Samsung devices alone, but none of them are rooted. I am looking for any users that may have a rooted samsung device that also has a custom ROM installed. I would like to get your feedback, does the game run ok on your device?

Any info you all can provide will be a great help!

Thanks so much for your time, support, and for playing DQ!

I have a regular samsung s4 and have no issues whatsoever. Not sure what rooted or not rooted means but its a stock pjone from att.

Thanks vexic! The issue is on the samsung end (apparently) and I was hoping some might has a Samsung device that is not running factory default software (rooted). I have a few emails out to Samsung but we are still working in the isses. It’s great you don’t see any issues on your devixe, one less type to worry about :smile:

Sent from my SM-N900T using Tapatalk

So sgs 2 runs perfectly aswell non rooted with jellybean

I have a few rooted devices. One of them, a Samsung Galaxy S II (i9100) has Dungeon Quest installed. It does not run a stock ROM but a Cyanmodgen based one under Android 4.4.2. Since the last 2 patches, I can confirm that things are not as good as before. Particularly battery life. The game makes the phone to boil to the point where you can no longer hold it; the screen and around where the camera is (I assume the CPU and/or GPU are there) are the main hotspots. The game used to run fine so I agree with some of the reviews in saying that the latest modifications are “killing” the processor/s or battery.
On that note, I am also running the game under a different rooted device, this time its an Android 4.2.1, Hisense Pro tablet and it runs fantastic there. Mind you it does get warm after playing a while, but nothing unexpected.
I could try running the game in other Samsung rooted devices with custom ROMs if that would help?

Thanks for the info! Could you try turning down display brightness before playing? That was a tip M@ssey posted and it seems to cut back on heat as well as battery consumption. So dq does not run in your sgs2 stock? Won’t even start or performs poorly in game?

Sent from my SM-N900T using Tapatalk

On my stock sgs2 it runs just fine.
Although the battery consumption in much higher compared to pre 1.4 even with lower brightness

Ok, thank you very much for the info! Do you have a Samsung galaxy note 8’ by chance?

Sent from my SM-N900T using Tapatalk

Nope sry but i could test it on a stock sgs4 aswell if thats needed

@TDaniel:
The brightness in the phone is typically between -35% to -65% as measured by the app Lux (com.vito.lux). So it is subzero compared to the “normal” brightness. So, that is not the “solution”. I have never tried to run DQ on a SGS2 stock. Unless I misunderstood your first post, the whole idea was about rooted Samsung devices and custom ROMs?
Now, I have not changed the version of the ROM whilst changing 3 versions of DQ and, as I mentioned before, originally the game was working “fine”. The last two updates have had that overheating problem.
However, since I posted (yesterday), I have been trying to figure out the root of the problem as a user. One thing that I did not have two versions ago is my character’s level, and with it my floor level. Which impacts in the amount of enemies at any particular time and, incidentally, as well, the amount of minions I have; currently 9 and about 3 skulls.
Since I do not want to loose my progress and, incidentally since the latest update I can no longer upload my character to the server, I cannot “restart” the game or start a new one afresh to confirm my current theory.
I wonder if it is the same “effect” to others, that since as they level, more enemies appear and thus more processing power required, thus, more heat/battery. Am I making sense?

Yup, I follow you. I don’t however understand the impact the last two builds would have had on your device since they added no paticular increase in assets and we didn’t change any rendering practices. I also don’t know why you can no longer upload your character data to the server. Can you explain that issue? Are you having time out issues when attempting to “upload” data?

Sent from my SM-N900T using Tapatalk

@TDaniel:
In the game, click on DQ Account, (signs in), then upload, it tries uploading and then a windows appears saying:
unknown error[]
A Okay

Since yesterday there have been some developments.
I have managed to level up my other account/device to the same point in terms of minions although not the same actual dungeon level, and the non-Samsung device does not heat itself the same. (it is still decent/expected).
On a happy note I think I have figured out the heat problem. It does not seem to happen (as bad) whenever I have the internet off on the device.
The i9100 is a 3G device, whilst the other is a Wi-Fi only.
So, the underlying problem might be with the game trying to load the ads off the internet. When I turn the internet off altogether, I still get the ads that have been pre-downloaded, but nothing “new” in that sense.
I will try testing to see if the type of connectivity makes a difference.
Today I did not have that much of a chance to play it as long on the Samsung device to notice categorically if that made a difference (turning the internet off) but will keep you posted.

Ok, thanks for the update.
I could see the 3g radio expelling more heat than the wifi radio.

I have a rooted Samsung galxy note 3 with a customrom (jb) (jackyaway). I have no problem with the game. Tested just now and I could upload to my account.

Hi,

my phone is a Samsung Galaxy SII (GT-i9100) and its rooted.. previously it's gingerbread and i upgraded it to JellyBean 4.1.2… DQ works Excellently.. except that sometimes (rarely)  i lose control over the walking toggle (the one on the left side; not the buttons ).. so far nothing bugs me in gaming… can't wait for the next patch :smiley: please include pets purchased in gold… it won't bother me if it ranges to like 10M gold… i don't care :smiley: as long as its balanced with the ones who buy with real cash :smiley:

Thanks,

Astor Blood Magician 96

Cool, thanks for the info. As expected samsung devices that run a mod rom seem to run our game like butter…it’s the stock rims that are giving us issues!
Pet test patch just went out…full release in a few days (fingers crossed)

Sent from my SM-N900T using Tapatalk

Hi. :smile:

I’m a newbie here at the forums. :smile: I have a Samsung Galaxy S (GT-I9000) and it is rooted. It has DQ installed in it and its having some graphic problems. :astonished: I created a topic about this yesterday here in forums. The loading screen works fine and the character selection screen but when I’m playing the game the graphics become color yellow and when I move my character it becomes green. The hp/mp/exp bar, move and skill button as well as the pause button are working perfectly but the field of the game as well as the character are having some problems.

It wasn’t like this when I first downloaded it but when I quit the game and after a while it, runs it again but it showed the graphic problems. And I also re-installed the game and it was working perfectly at first, again. But, when i quit and run it back again… Unfortunately, it showed the problem again. Please help. :frowning:

P.S. I do not run custom rom. But, If it works perfectly on custom rom, I’ll try installing cynogen mod in my phone. :smile:

Its working properly now. :smile: I just flashed a custom rom on my phone and poof its working! <3 Thanks guys! :smile:

Yup…that is typically the way it goes :frowning: sorry you had to go through that! Overall I am sure the device performs better as well!!

I have a rooted Samsung Galaxy S4 International (GT-I9505) with stock firmware Android 4.3 and custom kernel (ktoonz).
I can’t update to the latest version of the app (started a thread in support section regarding this).