Tapping to watch ads STILL crashing game

As I noted several days ago, installed new patch on my Samsung A9, and the game crashes EVERY SINGLE TIME that I tap the button to watch an ad for a boost. Game works fine if I do NOT tap the button to watch ads. I have not seen anyone else post about this, but assume I am not the only one experiencing this problem, so would you please respond to let us know that you are at least aware of this issue and working on it? Thanks.

  1. we released a small 3.1.1 patch several days ago (to try to address the shadow issue some players are seeing), do you have that patch?

  2. I did read your first post and tried the af boosts in several device…no crash on my end.

  3. do you have a rooted device or are you running custom firmware?

Thank you for the response.

  1. Yes, I already downloaded the newest patch. Still have the issue.
  2. OK
  3. No.

I just uploaded my characters to the cloud, deleted the game entirely from my phone, reinstalled it, then downloaded characters again. Tapped to watch an ad and…CRASH! I did not do a restart before reinstalling. Would that make any difference?

Not that I know of.
The only other thing I can think of is if you are using a VPN or have some other sort of ad blocking software on your device.

Not using either of those.

I even tried uninstalling again, wiping the phone’s cache partition, and reinstalling and downloading characters again. Still crashing anytime I tap to watch an ad. I watched them fairly often because I enjoyed getting the random boosts, but I guess I can’t anymore.