Can't Attack while moving/running

Hi
I am having problems with the game. My character can’t swing the sword when moving or running.

  1. I tried changing the control settings from default dynamic thumbstick to thumbstick bit still not workng.

  2. I tried lowering the graphics settings with no success.

  3. I tried using a different device an iPhone 7 plus and my character can attack while running.

My device is a Xiaomi Redmi 8A and just recently updated the android OS.

Is there any other steps I can do to resolve this?

Thank you!

2 Likes

You don’t have any problem. There are few attacks which could let you move like charge and whirlwind but in most of the attacks that the game provides you can’t move while you attack, is just the game mechanic.

2 Likes

I have the same issue. Any tips to fix it?

1 Like

some attacks immobilize you when used. like a Wizard using Comet. some Attacks can be used while moving. like a Wizard using Twister.

I have recently discovered that if you reduce the Cool Down low enough, you can’t move. Wizard Orb Skill has a CD of 1 second. with CD, I have gotten the CD down to 0.3 seconds. I have a +10% movement and can’t move while casting Orb continuously. with CD of 0.5 seconds, I can move. although I haven’t tested it yet, I think if I increase my Movement Speed even higher, I should be able to move while casting Orb, even if I get Orbs CD to 0.2 seconds or better. 0.2 attacks a second is 5 attacks a second, so you would have to have your Movement speed fast enough to move at least a yard or more in between each attack.

also, as @Ariel said, it is just part of game mechanics. I would suggest finding a Skill you like to use that allows you to move while attacking.

2 Likes