No item drop at all

When i change my pick up rarity to epic+ there is no item drop at all except epic and legend and up. I believe its an annoying bug, because there is no point using my pet imp when there is no item drop, when i set to normal+ again but of course the imp won’t pick the item. The item start to drop again. I tried to use the pick up rarity epic+ for 2 maps and there is no item drop at all for 2 maps. Amazing. Is the problem from the server or my device?

Hey! Thanks for the bug report. Are you sure, that the imp haven’t picked it up? The imp got much faster since 2.1. Try change the pet to Hound or Fairy. Does it still happen to you?

Absolutely sure. The imp pick up the item, but no item drop from monster. I tried once set to normal, kill some monsters until an item drop, then set to epic+ , my imp pick the scattered item on the ground. But as long as i set to magic+, no normal item drop, set to rare+ no normal and magic drop, set to epic+ no normal, magic and rare drop, etc. Same thing happen with imp, fairy and hound. Thank you, hope i can enjoy my adventure with my imp again.

That’s weird. Cannot reproduce it at my end. I think it’s an account dependent issue. Please contact the support including your DQ-Account.

@Frosthawk Hi, I think you don’t get the item drop system.
For example, if you set it to epic+, you will only loot epic and eternal drops while the items with lower than epic rarity will be taken by the imp which will be converted into something else with its tossing animation after getting 5 unused items on the ground.
If you set it to normal+, you will loot all items on the ground, however, making the imp useless as it won’t have items to convert.